PAT-1152 Google Recruitment (20 分)

1152 Google Recruitment (20 分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

思路

题目不多说,就是从长度为L的数字中找出第一个长度为K的素数。

很好做,但是我主要说一下他的坑点:

  1.  判断素数(0、1不是素数,2、3是素数)
  2. 输出素数(可以用printf的可变宽度参数)

第一次用VS2010做题,感觉这个IDE还可以。

代码 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>

using namespace std;

const int maxn = 10000;
char a[maxn];

int pow10(int n){
	int sum = 1;
	if (n < 2) return -1;
	for (int i = 0; i < n; i++){
		sum *= 10;
	}
	return sum;
}

bool judge(int n){
	if (n <= 1) return false;
	if (n == 2) return true;
	if (n == 3) return true;

	for(int i = 2; i*i <= n; i++){
		if(n%i == 0){
			return false;
		}
	}
	return true;
}

int main(){
	int ll,k;
	scanf("%d%d", &ll, &k);
	getchar();
	scanf("%s",a);
	for (int i = 0; i <= ll-k; i++) {
		int sum = 0;
		for (int j = 0; j < k; j++){
			sum = sum*10 + a[i+j] - '0';
		}
		if (judge(sum)) {
			if(sum < pow10(k-1)){
				printf("%.*d\n",k, sum);
			} else {
				printf("%d\n", sum);
			}
			return 0;
		}
	}
	printf("404\n");
	return 0;
}
发布了148 篇原创文章 · 获赞 52 · 访问量 24万+

猜你喜欢

转载自blog.csdn.net/m0_38072683/article/details/94414937