PAT 1152 Google Recruitment python解法

1152 Google Recruitment (20 分)
In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
The natural constant e is a well known transcendental number(超越数). The first several digits are:
e=2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:
For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:
20 5
23654987725541023819
Sample Output 1:
49877
Sample Input 2:
10 3
2468024680
Sample Output 2:
404

题意:给出一个很大的整数,在其中找出指定长度的第一个素数。

解题思路:
1.首先要解决判断一个数是不是素数,参考了博文判断一个数是不是质数(素数),3种方式介绍中第三种方式。
2.然后只需要切割字符串来判断就行了。

import math
def isprime(n):
    if n <= 3:
        return n > 1
    if n%6 != 1 and n%6 != 5:
        return False
    for i in range(5,int(math.sqrt(n)),6):
        if n%i==0 or n%(i+2)==0:
            return False
    return True
n , m = input().split()
s = input()
for i in range(int(m), int(n)+1):
    if isprime(int(s[i-int(m):i])):
        print(s[i-int(m):i])
        break
else:
    print('404')

猜你喜欢

转载自blog.csdn.net/qq_36936510/article/details/86577033