AVL树——自平衡二叉搜索树

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/JoJoSIR/article/details/84454639

概念

AVL(Adelson-Velskii and Landis)树得名于它的发明者 G.M. Adelson-Velsky 和 E.M. Landis,他们在 1962 年的论文《An algorithm for the organization of information》中发表了它。
AVL树是一种自平衡二叉搜索树。

特征

  1. 满足二叉搜索树的特征,即任何一个节点的值比左孩子的值大,比右孩子的值小
  2. 在二叉搜索树的基础上,任何一个节点的左右子树高度差不超过1

构建AVL树

参考博客:https://www.cnblogs.com/skywang12345/p/3576969.html

出现不平衡的4种情况


  1. LL: LeftLeft,也称为"左左"。插入或删除一个节点后,根节点的左子树的左子树还有非空子节点,导致"根的左子树的高度"比"根的右子树的高度"大2,导致AVL树失去了平衡。
  2. RR:RightRight,称为"右右"。插入或删除一个节点后,根节点的右子树的右子树还有非空子节点,导致"根的右子树的高度"比"根的左子树的高度"大2,导致AVL树失去了平衡。
  3. LR:LeftRight,也称为"左右"。插入或删除一个节点后,根节点的左子树的右子树还有非空子节点,导致"根的左子树的高度"比"根的右子树的高度"大2,导致AVL树失去了平衡。
  4. RL:RightLeft,称为"右左"。插入或删除一个节点后,根节点的右子树的左子树还有非空子节点,导致"根的右子树的高度"比"根的左子树的高度"大2,导致AVL树失去了平衡。

旋转

1. LL的旋转

在这里插入图片描述

2. RR的旋转

3. LR的旋转

4. RL的旋转

在这里插入图片描述

练习题

PAT 1066 Root of AVL Tree

Description

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在这里插入图片描述


在这里插入图片描述

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

AC code

代码参考:https://www.liuchuo.net/archives/2178

#include <stdio.h>
#include <iostream>
using namespace std;

struct node{
    int val;
    struct node *left, *right;
};

int getHeight(node *root){
    if(root == NULL) return 0;
    return max(getHeight(root->left), getHeight(root->right)) + 1;
}

node *rotateLeft(node *root){
    node *t = root->right;
    root->right = t->left;
    t->left = root;
    return t;
}

node *rotateRight(node *root){
    node *t = root->left;
    root->left = t->right;
    t->right = root;
    return t;
}

node *rotateLeftRight(node *root){
    root->left = rotateLeft(root->left);
    return rotateRight(root);
}

node *rotateRightLeft(node *root){
    root->right = rotateRight(root->right);
    return rotateLeft(root);
}

node *insert(node *root, int val){
    if(root == NULL){
        root = new node();
        root->val = val;
        root->left = NULL; root->right = NULL;
    }else if(val < root->val){
        root->left = insert(root->left, val);
        if(getHeight(root->left) - getHeight(root->right) == 2)
            root = val < root->left->val? rotateRight(root): rotateLeftRight(root);
    }else{
        root->right = insert(root->right, val);
        if(getHeight(root->left) - getHeight(root->right) == -2)
            root = val > root->right->val? rotateLeft(root): rotateRightLeft(root);
    }
    return root;
}

int main(){
    int n, val;
    scanf("%d", &n);
    node *root = NULL;
    for(int i = 0; i < n; i++){
        scanf("%d", &val);
        root = insert(root, val);
    }
    printf("%d", root->val);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/JoJoSIR/article/details/84454639
今日推荐