Matrix(二维树状数组)

A - Matrix

Time Limit: 3000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

#include<stdio.h>
#include<iostream>
using namespace std;

int n,m;
int a[1005][1005];

int lowbit(int x)
{
    return x&(-x);
}

void update(int i,int j,int num)
{
    int tj;
    while(i<=n)
    {
        tj = j;
        while(tj<=n)
        {
            a[i][tj] += num;
            tj += lowbit(tj);
        }
        i += lowbit(i);
    }
}

int getsum(int i,int j)
{
    int ans = 0;
    int tj;
    while(i>0)
    {
        tj = j;
        while(tj>0)
        {
            ans += a[i][tj];
            tj -= lowbit(tj);
        }
        i -= lowbit(i);
    }
    return ans;
}

int main()
{
    int t,i,j,a1,b1,c1,d1;
    char ch[2];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1; i<=n; i++)
        {
            for(j=1 ;j<=n; j++)
            {
                a[i][j] = 0;
            }
        }
        while(m--)
        {
            scanf("%s",ch);
            if(ch[0] == 'C')
            {
                scanf("%d%d%d%d",&a1,&b1,&c1,&d1);
                update(a1,b1,1);
                update(c1+1,b1,-1);
                update(a1,d1+1,-1);
                update(c1+1,d1+1,1);
            }

            if(ch[0] == 'Q')
            {
                scanf("%d%d",&a1,&b1);
                printf("%d\n",getsum(a1,b1)%2);
            }
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wonder__/article/details/80255788