HDU 1004 ( Let the Balloon Rise )

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/82081713
                                Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 147583 Accepted Submission(s): 58612

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
typedef struct student{
    int num;
    int num1;
};
bool com(const student &a,const student &b)
{
    if(a.num<b.num)
        return true;
    else
        return false;
}
int main()
{
    int n,m=0,t=0,i,j;
    student c[1000];
    string a[1000],b;
    while(cin>>n)
    {
        if(n==0)
            break;
        for(i=0;i<1000;i++)
        {
            c[i].num=0;
            c[i].num1=i;
        }
        cin>>a[0];
        t=1;
        for(i=1;i<n;i++)
        {
            cin>>b;
            for(j=0;j<t;j++)
            {
                if(b==a[j])
                {
                    c[j].num++;
                    m=1;
                    break;
                } 
            }
            if(m==0)
            {
                a[t]=b;
                t++;
            }
            m=0;
        }
        sort(c,c+t,com);
        cout<<a[c[t-1].num1]<<endl;
        m=0;
        t=0;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/82081713