HDU - 1004 Let the Balloon Rise

Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

本题题意:本题就是要让你找出出现次数最多的颜色,输入0退出。

本题思路:做一个map映射,一个储存颜色,另一个储存出现次数,找到出现次数最多的,映射出颜色即可。

AC代码如下:

#include<iostream>
using namespace std;
#include<string>
#include<map>
int main()
{
	string s,s1;
	int n;
	
	while (cin >> n&&n)
	{
		map<string, int>mp;
		
		while (n--)
		{	
			cin >> s;
			mp[s]++;
		//存储气球信息
		}
		int max1 = 0;
		//迭代map
		for (map<string, int>::iterator it = mp.begin(); it != mp.end(); it++)
		{
			if (it->second > max1)
			{
				max1 = it->second;
				s1 = it->first;
			}
		}
		cout << s1 << endl;
	}

	return 0;
}
发布了40 篇原创文章 · 获赞 10 · 访问量 2568

猜你喜欢

转载自blog.csdn.net/lsdstone/article/details/101113613