Let the Balloon Rise HDU - 1004

版权声明:本文为博主胡乱瞎写,如有需要,随便转载,顺带给个momo哒。 https://blog.csdn.net/rangran/article/details/81913633

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main()
{
    int n,m,t,x,i,j;
    char s[1020][20];
    int a[1001],b[1001];
    while(~scanf("%d",&n)&&n!=0)
    {
        for(i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            b[i]=strlen(s[i]);
            a[i]=1;
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(b[i]==b[j])
                {
                    if(strcmp(s[i],s[j])==0)
                        a[i]++;
                }
            }
        }
        m=a[0];
        t=b[0];
        x=0;
        for(i=0;i<n;i++)
        {
            if(a[i]>m)
            {
                m=a[i];
                x=i;
                t=strlen(s[i]);
            }
        }
        for(i=0;i<t;i++)
        {
            if(i==t-1)
                printf("%c\n",s[x][i]);
            else
                printf("%c",s[x][i]);
        }
    }
    return 0;
}

strcmp用法: 

函数名: strcmp
功  能: 字符串比较
用  法: int strcmp(const char *s1, const char *s2);
返回值: 根据ASCII码比较,若参数s1和s2字符串相同则返回0,s1若大于s2则返回大于0的值,s1若小于s2则返回小于0的值
说  明: 它是区分大小写比较的,如果希望不区分大小写进行字符串比较,可以使用stricmp函数
程序例:

#include <string.h>
#include <stdio.h>

int main(void)
 {
    char *a = "aBcDeF";
    char *b = "AbCdEf";
    char *c = "aacdef";
    char *d = "aBcDeF";
    printf("strcmp(a, b) : %d\n", strcmp(a, b));  // 输出:1
    printf("strcmp(a, c) : %d\n", strcmp(a, c));  // 输出:-1
    printf("strcmp(a, d) : %d\n", strcmp(a, d));  // 输出:0
    return 0;
 }

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81913633