HDU-1004 Let the Balloon Rise

HDU-1004 Let the Balloon Rise

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 65536/32768K (Java/Other)

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1004

分析

题意:输入多种颜色,然后输出颜色最多的那种颜色。还是很好理解的,就跟找众数差不多的。

思路:原本是练习字典树的用法的,结果全用map写的,主要是因为字典树不会…..map实现大家看一下代码就可以了,解法很简单。

代码

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;
int main()
{
    map<string,int>mp;
    int n;
    while (~scanf("%d",&n),n!=0)
    {
        char str[1005],ss[1005];
        int sum=-1;
        for (int i=0;i<n;i++)
        {
            cin>>str;
            mp[str]++;
            if (sum<mp[str])
            {
                sum=mp[str];
                strcpy(ss,str);
            }
        }
        cout<<ss<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/bestfm/article/details/80185215