HDOJ--1004Let the Balloon Rise

原题链接


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
 
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
 
  
red pink
 
思路1:建立字符串数组,比较新加入的字符串是否相同,相同计数+1,最后寻找最大计数
#include<stdio.h>
#include<string.h>
int main()
{
	char Color[1001][16];
	int ColorNum[1001];
	char ch[16];
	int i,j,n,flag;
	//最坏情况是N平方 
	while((scanf("%d",&n))&&n!=0)
	{
		memset(ColorNum,0,sizeof(ColorNum));
		memset(Color,0,sizeof(Color));
		scanf("%s",ch);
		strcpy(Color[1],ch);
		ColorNum[1]++;
		ColorNum[0]++;
		for(i=2;i<=n;i++)
		{
			scanf("%s",ch);
			flag=0;
			for(j=1;j<=ColorNum[0];j++)
			{
				if(strcmp(ch,Color[j])==0)
				{
					ColorNum[j]++;
					flag=1;
					break;
				}
			}
			if(flag==0)
			{
				ColorNum[0]++;
				strcpy(Color[ColorNum[0]],ch);
			}
		}
		int max=1;
		for(i=2;i<=ColorNum[0];i++)
		{
			if(ColorNum[i]>ColorNum[max])	max=i;
		}
		printf("%s\n",Color[max]);
	}
	
	return 0;
}

思路2:在字符串输入时即比较

#include<stdio.h>
#include<string.h>
int main()
{
	char Color[1001][16];
	int i,j,n;
	//N平方 
	while((scanf("%d",&n))&&n!=0)
	{
		for(i=0;i<n;i++)
			scanf("%s",Color[i]);
		int max,sum,k;//max记录最大,sum记录当前最大,k记录哪一个 
		max=k=0;
		for(i=0;i<n;i++)
		{
			sum=0;
			for(j=i+1;j<n;j++)
			{
				if(strcmp(Color[i],Color[j])==0)
				{
					sum++;
				}
			}
			if(sum>max)
			{
				max=sum;
				k=i;
			}
		}
		printf("%s\n",Color[k]);
	}
	
	return 0;
}


猜你喜欢

转载自blog.csdn.net/y_cnew/article/details/79828347