hdoj 1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 139447    Accepted Submission(s): 55121


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
 
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
 
  
red pink
 

Author
WU, Jiazhi
 

Source

map容器的元素数据是由一个键值和一个映照数据组成的,键值和映射之间具有一一映照的关系,所以这道题用这个容器会比我们普通的字符串+数组处理起来方便的多,如果用字符串的话还得加一个字符串比较函数

#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
using namespace std;
int main(){
	map<string,int>m;
	map<string,int>::iterator it;//设置迭代器
	int N;
	string str,ans;
	while(scanf("%d",&N)!=EOF&&N!=0){
		m.clear();
		while(N--){
			cin>>str;
			m[str]++;
		}
		int max=-1;
		string maxcolor;
		for(it=m.begin();it!=m.end();it++){
			if((*it).second>max){
				max=(*it).second;
				maxcolor=(*it).first;
			}
		}
		cout<<maxcolor<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/dear_jia/article/details/80053759