L - Let the Balloon Rise

题目:

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题意:

给你一个数字 N ,代表有N个气球,让你求出出现次数最多的气球的颜色;

代码如下:

(1)使用数组:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int t;
char map[10001][20];//存储气球的颜色;
int sum[10001];

int main()
{
    while(~scanf("%d",&t)&&t)
    {
        memset(sum,0,sizeof sum);
        int i,j;
        for(i=0;i<t;i++)
        {
            scanf("%s",map[i]);
            for(j=0;j<i-1;j++)
            {
                if(strcmp(map[i],map[j])==0)//把这个气球的颜色和以前出现过的气球进行比较,如果颜色相同就加1;
                    sum[i]=sum[i]+1;//前面的没出现一个颜色相同的,这个颜色的气球个数就加1;
            }
        }
        int s=0;
        for(i=0;i<t;i++)//进行遍历,找出出现次数最多的颜色;
        {
            if(sum[i]>s)
            {
                s=i;//标记出现次数最多的颜色是第几个气球;
            }
        }
        printf("%s\n",map[s]);//输出这个气球的颜色;
    }
    return 0;
}

(2)使用map容器:

#include<iostream>
#include<map>
#include<string>
#include<algorithm>
using namespace std;

const int MAX=10010;

int main()
{
    int n;
    char col[20];
    while(cin>>n)
    {
        if(n==0)
            break;
        map<string,int> balloons;
        for (int i=0; i<n; i++)
        {
            cin>>col;
            balloons[col]++;
        }
        map<string,int>::iterator p,m;
        p=m=balloons.begin();
        for (; p!=balloons.end(); p++)
        {
            if(p->second > m->second) m=p;
        }
        cout<<m->first<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81085785