13----Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
方法:对于此找最多的相同数的问题,可以将其转化,采取取尺法来做
利用排序函数,像比较简单的插入排序,冒泡,选择(本人擅长选择)
将相同的排在一起,利用取尺法的代码模板做即可

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cstring>
#include<iomanip>
#include<math.h>
#include<algorithm>
using namespace std;
char s[1005][16];
int n;
void sor()
{
    char f[16];
    for(int i=0;i<n-1;i++)
    {
        for(int j=i+1;j<n;j++)
        if(strcmp(s[i],s[j])<0)
        {
            strcpy(f,s[i]);
            strcpy(s[i],s[j]);
            strcpy(s[j],f);
        }
    }
}
int main()
{
    int k;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            {
                cin>>s[i];
            }
            sor();
            int l=0,r=0,ans=0,sum=0;
       for(int l=r;l<n;l=r+1)//取尺法
       {
           ans=0;
           for(r=l;r<n&&strcmp(s[l],s[r])==0;r++)
           {
               ans++;
               if(ans>sum)
               {
                   sum=ans;
                   k=r;
               }
           }
       }
cout<<s[k]<<endl;
    }
    return 0;
}

本人因为刚学c++,对string的应用不太好,希望有明白string用法的人讲解一下
谢谢

猜你喜欢

转载自blog.csdn.net/Nacht_one/article/details/82155138