算法笔记——Codeup Contest 100000577 Problem B Hello World for U

题目描述
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:
在这里插入图片描述
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出
For each test case, print the input string in the shape of U as specified in the description.

样例输入
helloworld!
样例输出
在这里插入图片描述

代码

#include <cstdio>
#include <cstring>
int main() {
	char str[85] ;
	int n, side, mid ;
	while (scanf ("%s",str)!=EOF) {		//多组数据 
		n = strlen (str) ;
		side = (n+2) / 3;				//side指的是两边垂直的字母数 
		mid = n - side*2 ;				//mid指的是中间空的空格数 
		for (int i=0; i<side; i++) {
			if (i!=side-1) {			//不是最后一行 
				printf ("%c", str[i]) ;
				for (int j=0; j<mid; j++) {
					printf (" ") ;
				}
				printf ("%c\n", str[n-1-i]) ;	
			} else {					//最后一行 
				for (int i=side-1; i<side+mid+1; i++) {
					printf ("%c", str[i]) ;
				}
			}
		}
	}
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/arthur01p/article/details/86555797