1009 Product of Polynomials (25 分)(多项式模拟)

https://pintia.cn/problem-sets/994805342720868352/problems/994805509540921344

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

polynomials
多项式

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
struct node{
    double a;
    int b;
}A[15],B[15];
double ans[2005];
vector<int> v;
int main(){
    int n,m;
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%d%lf",&A[i].b,&A[i].a);
    scanf("%d",&m);
    for(int i=1;i<=m;i++) scanf("%d%lf",&B[i].b,&B[i].a);
    for(int i=1;i<=n;i++){
    	for(int j=1;j<=m;j++){
    		ans[A[i].b+B[j].b]+=A[i].a*B[j].a;
	}	 
    }
    for(int i=2000;i>=0;i--){
    	if(ans[i]!=0) v.push_back(i);
    }
    cout<<v.size();
    for(int i=0;i<v.size();i++){
	printf(" %d %.1f",v[i],ans[v[i]]);
    }
    return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/101938267