PAT甲级1065

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, Band C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
#include<bits/stdc++.h>
using namespace std;
#define ll long long

int main(){
	int t;
	scanf("%d", &t);
	ll a, b, c;
	for(int i = 1; i <= t; i++){
		scanf("%lld %lld %lld", &a, &b, &c);
		ll res = a + b;
		bool flag;
		if(a > 0 && b > 0 && res < 0) flag = true;
		else if(a < 0 && b < 0 && res >= 0) flag = false;
		else if(res > c) flag = true;
		else flag = false;
		if(flag)
			printf("Case #%d: true\n", i);
		else
			printf("Case #%d: false\n", i);	
	}
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6021

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/87085100