HDU 1452 Happy 2004 (唯一分解定理+积性函数)

Problem Description

Consider a positive integer X,and let S be the sum of all positive integer divisors of 200 4 X 2004^X . Your job is to determine S modulo 29 29 (the rest of the division of S by 29 29 ).

Take X = 1 X = 1 for an example. The positive integer divisors of 200 4 1 2004^1 are 1 , 2 , 3 , 4 , 6 , 12 , 167 , 334 , 501 , 668 1, 2, 3, 4, 6, 12, 167, 334, 501, 668 , 1002 1002 and 2004 2004 . Therefore S = 4704 S = 4704 and S modulo 29 29 is equal to 6 6 .

Input

The input consists of several test cases. Each test case contains a line with the integer X ( 1 < = X < = 10000000 ) X (1 <= X <= 10000000)

A test case of X = 0 X = 0 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the result of S modulo 29 29 .

Sample Input

1
10000
0

Sample Output

6
10
题意: 2004 2004 x x 次方的因子和模 29 29 的值。

先来引入几个定理:

  • 唯一分解定理:

所有数都可以被分解成 a = p 1 c 1 p 2 c 2 . . . p k c k a=p_{1}^{c_{1}}*p_{2}^{c_{2}}*...*p_{k}^{c_{k}}

  • 因子和定理:

如果 p p 是质数

s u m = ( p 1 0 + . . . + p 1 c 1 ) ( p 2 0 + . . . + p 2 c 2 ) . . . ( p k 0 + . . . + p k c k ) sum=(p_{1}^0+...+p_{1}^{c_{1}})*(p_{2}^0+...+p_{2}^{c_{2}})*...*(p_{k}^0+...+p_{k}^{c_{k}})。

= ( p 1 c 1 + 1 1 p 1 1 ) ( p 2 c 2 + 1 1 p 2 1 ) . . . ( p k c k + 1 1 p k 1 ) =(\frac{p_{1}^{c_{1}+1}-1}{p_{1}-1})*(\frac{p_{2}^{c_{2}+1}-1}{p_{2}-1})*...*(\frac{p_{k}^{c_{k}+1}-1}{p_{k}-1})

2004 = 2 2 3 167 2004=2^2*3*167

所以: 200 4 n = 2 2 n 3 n 16 7 n 2004^n=2^{2*n}*3^n*167^n

200 4 n 2004^n 的因子和就是 ( 2 2 n + 1 1 2 1 ) ( 3 n + 1 1 3 1 ) ( 16 7 n + 1 1 167 1 ) (\frac{2^{2*n+1}-1}{2-1})*(\frac{3^{n+1}-1}{3-1})*(\frac{167^{n+1}-1}{167-1})

这样再对除法使用一些逆元就好了。

AC代码:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
    int ret = 0, sgn = 1;
    char ch = getchar();
    while (ch < '0' || ch > '9')
    {
        if (ch == '-')
            sgn = -1;
        ch = getchar();
    }
    while (ch >= '0' && ch <= '9')
    {
        ret = ret * 10 + ch - '0';
        ch = getchar();
    }
    return ret * sgn;
}
inline void Out(int a)
{
    if (a > 9)
        Out(a / 10);
    putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
    return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(int m, int k, int mod)
{
    ll res = 1, t = m;
    while (k)
    {
        if (k & 1)
            res = res * t % mod;
        t = t * t % mod;
        k >>= 1;
    }
    return res;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
    return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
    if (b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    int g = exgcd(b, a % b, x, y);
    int t = x;
    x = y;
    y = t - a / b * y;
    return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
    int d, x, y;
    d = exgcd(a, p, x, y);
    if (d == 1)
        return (x % p + p) % p;
    else
        return -1;
}

///中国剩余定理模板
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
    int M = 1, y, x = 0;
    for (int i = 0; i < n; ++i) //算出它们累乘的结果
        M *= a[i];
    for (int i = 0; i < n; ++i)
    {
        int w = M / a[i];
        int tx = 0;
        int t = exgcd(w, a[i], tx, y); //计算逆元
        x = (x + w * (b[i] / t) * x) % M;
    }
    return (x + M) % M;
}

int n;
int ans, a, b, c;

int main()
{
    while (sd(n) && n)
    {
        a = (qpow(2, 2 * n + 1, 29) - 1) * (qpow(1, 27, 29));
        b = (qpow(3, n + 1, 29) - 1) * (qpow(2, 27, 29));
        c = (qpow(167, n + 1, 29) - 1) * (qpow(166, 27, 29));
        ans = a * b * c % 29;
        cout << ans << endl;
    }
    return 0;
}
发布了611 篇原创文章 · 获赞 390 · 访问量 20万+

猜你喜欢

转载自blog.csdn.net/qq_43627087/article/details/103570830
今日推荐