HDU 1452 Happy 2004 因数和

Problem Description

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the result of S modulo 29.

扫描二维码关注公众号,回复: 3526447 查看本文章

Sample Input

 

1 10000 0

Sample Output

 

6 10

Source

ACM暑期集训队练习赛(六)

 代码如下:

/*
此题是求2004^x%29的因子和。。。
首先:
任何一个数可以化成几个素因子幂的乘积的形式。。
2004=2^2*3*167;
这里167这个数字可以化简下,167%29=22;
令g(p, e) = (p^(e+1) - 1) / (p-1), 其中p为素因子,e为素因子的幂
则s(n) = g(p1, e1) * g(p2, e2) * ... * g(pk, ek)。
因此:
因子和可化为:s(2004^n)=[(2^(2n+1)-1)/1]*[(3^(n+1)-1)/2]*[22^(n+1)/21]%29;
这里可以用逆元进行运算
1的逆元为1;
2的逆元为15;
21的逆元为18;
所以式子进一步简化为:
s(2004^n)=(2^(2n+1)-1)*(3^(n+1)-1)*15*(22^(n+1))*18%29;
15*28又能进一步取余
所以最终式子为:
s(2004^n)=(2^(2n+1)-1)*(3^(n+1)-1)*(22^(n+1))*9%29;
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n;
int fastpow (int a,int b)
{
    int sum=1;
    while (b>0)
    {
        if(b%2)
        {
            sum=sum*a%29;
        }
        a=a*a%29;
        b>>=1;
    }
    return sum;
}
int main()
{
    while (scanf("%d",&n)!=EOF&&n)
    {
        int a,b,c;
        a=fastpow(2,(n<<1)+1)-1;
        b=fastpow(3,n+1)-1;
        c=fastpow(22,n+1)-1;
        printf("%d\n",9*a*b*c%29);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/82949135