杭电Oj刷题(2025)

查找最大元素

题目描述:

对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

Input

输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。

Output

对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

Sample Input

abcdefgfedcba 
xxxxx

Sample Output

abcdefg(max)fedcba 
x(max)x(max)x(max)x(max)x(max)

通过答案:

#include <stdio.h>
int main()
{
	char str[100];
	int i,max,k;
	while(scanf("%s",&str)!=EOF){            // %s:输入一串字符 
		max=0;
	    k=0;
	    for(i=0;str[i]!='\0';i++){
		    if(str[i]>max){
			    max=str[i];
			    k=i;
		    }
	    }
	    for(i=0;str[i]!='\0';i++){
		    if(str[i]==str[k])
			    printf("%c(max)",str[i]);          //在最大元素后面加(max)
		    else
			    printf("%c",str[i]);	
	    }
		printf("\n");
	}
	return 0;
}
发布了55 篇原创文章 · 获赞 0 · 访问量 1014

猜你喜欢

转载自blog.csdn.net/ZhangShaoYan111/article/details/104138461