PAT 甲级 A1051

1051 Pop Sequence (25分)

题目描述

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4

输入格式

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

输出格式

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

总结

  1. 题目大概意思是,给出栈最大容量和需要入栈的数字,让你判断给定的出栈序列是否合法。
  2. 首先设置一个数组,来存储一行的出栈序列。设当前待入栈的元素为num,栈顶元素位data[i],用一个while循环直到num == data[i]时跳出,然后再判断这个栈是否超出了最大容量m,循环执行。

AC代码

#include <iostream>
#include<stack>
using namespace std;
int main()
{
	int m, n, k, num, data[1005];
	stack<int> s;
	scanf("%d%d%d", &m, &n, &k);
	getchar();
	while (k--) {
		bool flag = true;
		while (!s.empty()) s.pop();
		num = 1;  //当前入栈元素
		for (int i = 0; i < n; i++) {
			scanf("%d", &data[i]);
		}
		for (int i = 0; i < n; i++) {
			if (s.empty() && num <= n) {
				s.push(num++);  //入栈元素序号+1
			}
			while (s.top() != data[i] && num <= n) {
				s.push(num++);
			}
			if (s.size() > m || s.top() != data[i]) {  //出栈序列不合法也会导致 s.top() != data[i] 
				flag = false;
				break;
			}
			s.pop();
		}
		if (flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}
发布了16 篇原创文章 · 获赞 0 · 访问量 356

猜你喜欢

转载自blog.csdn.net/qq_38507937/article/details/104326453