PAT A1099 Build A Binary Search Tree (30分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805367987355648

题目描述
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述

输入
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

输出
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

样例输入
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

样例输出
58 25 82 11 38 67 45 73 42

代码

#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;

const int MAXN = 110;
int N;
int Seq[MAXN], res[MAXN];
int Count = 0;

struct node {
    int lchild;
    int rchild;
    int data;
} Node[MAXN];

void inorder(int root) {
    if(root == -1) 
    	return;
    inorder(Node[root].lchild);
    Node[root].data = Seq[Count++];
    inorder(Node[root].rchild);
}

void layerorder(int root) {
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int now = q.front();
        q.pop();
        Count++;
        printf("%d", Node[now].data);
        if(Count < N) printf(" ");
        if(Node[now].lchild != -1) {
            q.push(Node[now].lchild);
        }
        if(Node[now].rchild != -1) {
            q.push(Node[now].rchild);
        }
    }
}

int main(int argc, char const *argv[]) {
    scanf("%d", &N);
    int left, right;
    for (int i = 0; i < N; ++i) {
        scanf("%d%d",&left, &right);
        Node[i].lchild = left;
        Node[i].rchild = right; 
    }
    for (int i = 0; i < N; ++i)
        scanf("%d", &Seq[i]);
    sort(Seq, Seq + N);
    inorder(0);
    Count = 0;
    layerorder(0);
    return 0;
}
发布了364 篇原创文章 · 获赞 13 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/105447893