1099 Build A Binary Search Tree (30)(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct Node
{
    int data,left,right;
}node[150];
int n;
int num[150];
int index = 0;
int root = 0;
void dfs(int x)
{
    if(x==-1)
        return ;
    dfs(node[x].left);
    node[x].data = num[index++];
    dfs(node[x].right);
}

int main()
{
    cin>>n;
    int l,r;
    for(int i=0; i<n; i++)
    {
        cin>>l>>r;
        node[i].left = l;
        node[i].right = r;
    }
    for(int i=0; i<n; i++)
        cin>>num[i];
    sort(num,num+n);
    dfs(root);
    queue<int> q;
    q.push(root);
    int cnt = 1;
    while(!q.empty())
    {
        int now = q.front();
        cout<<node[now].data;

        if(cnt <n)
            cout<<" ";
        cnt++;
        q.pop();
        if(node[now].left!=-1)  q.push(node[now].left);
        if(node[now].right!=-1) q.push(node[now].right);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38851184/article/details/81335078