1099 Build A Binary Search Tree(30 分)(cj)

1099 Build A Binary Search Tree(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next Nlines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

 思路 搜索二叉树的先序遍历是数组的从小到大遍历顺序,然后用先序遍历填充二叉树 再层序遍历。

code

#pragma warning(disable:4996)
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int arr[105][2];
int tree[105];
int val[105];
void preorder(int pos);
void levelorder(int pos);
int idex = 0;
int main() {
	int n;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		cin >> arr[i][0] >> arr[i][1];
	}
	for (int i = 0; i < n; ++i) {
		cin >> val[i];
	}
	sort(val, val+n);
	preorder(0);
	levelorder(0);
	system("pause");
	return 0;
}
void preorder(int pos) {
	if (pos == -1) return;
	preorder(arr[pos][0]);
	tree[pos] = val[idex++];
	preorder(arr[pos][1]);
}
void levelorder(int pos) {
	queue<int> q;
	bool f = 1;
	q.push(pos);
	while (!q.empty()) {
		int x = q.front();
		q.pop();
		if (f) f = 0;
		else cout << ' ';
		cout << tree[x] ;
		for (int i = 0; i < 2; ++i) {
			if (arr[x][i] != -1) q.push(arr[x][i]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82467084