PAT (Advanced Level) 1099 Build A Binary Search Tree (30 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/87876684

1099 Build A Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.
    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
    figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

Code:

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>
#pragma warning(disable:4996)
using namespace std;
struct Node
{
	int key;
	int lchild, rchild;
	Node() { lchild = rchild = -1; }
};
vector<Node> tree;
vector<int> squ;
int num = 0;
void inOrder(int root)
{
	if (root == -1)
		return;
	inOrder(tree[root].lchild);
	tree[root].key = squ[num++];
	inOrder(tree[root].rchild);
}
void levelOrder(int root)
{
	queue<int> q;
	q.push(root);
	while (!q.empty())
	{
		int t = q.front();
		q.pop();
		printf("%d%c", tree[t].key, (num-- == 1 ? '\n' : ' '));
		if (tree[t].lchild != -1) q.push(tree[t].lchild);
		if (tree[t].rchild != -1) q.push(tree[t].rchild);
	}
}
int main()
{
	int n;
	scanf("%d", &n);
	tree.resize(n);
	for (int i = 0; i < n; i++)
		scanf("%d%d", &tree[i].lchild, &tree[i].rchild);
	squ.resize(n);
	for (int i = 0; i < n; i++)
		scanf("%d", &squ[i]);
	sort(squ.begin(), squ.end());
	inOrder(0);
	levelOrder(0);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/87876684