pat 1099. Build A Binary Search Tree (30)

1099. Build A Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greater than or equal to the node's key. Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42



#include<iostream>
#include<algorithm>
#include<queue>


using namespace std;


class node{
public:int l,r,d;
};
bool cmp(int a,int b){
return a<b;
}


int n,x=0;
node tree[101];
int arr[101];


int med_order(int h){
if(h==-1) return 0;
med_order(tree[h].l);
tree[h].d=arr[x++];
med_order(tree[h].r);
return 0;
}


int main(){


int n;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>tree[i].l>>tree[i].r;
}


for(int i=0;i<n;i++)
cin>>arr[i];


sort(arr,arr+n,cmp);


med_order(0);


queue<int> q;
int t;
q.push(0);
int tt=0;
while(!q.empty())
{
t=q.front();
q.pop();
if(tt==0) cout<<tree[t].d,tt++;
else cout<<" "<<tree[t].d;
if(tree[t].l!=-1) q.push(tree[t].l);
if(tree[t].r!=-1) q.push(tree[t].r);

}
}




猜你喜欢

转载自blog.csdn.net/var1994/article/details/52462690