PAT--1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int dig[200];
    long n,m;
    cin>>n>>m;
    int k = 0;
    int flag=0;
    long sum = n+m;
    if(sum<0)
        cout<<"-";
    int tempsum =abs(sum);


    do{
        dig[k++] = tempsum%10;
        tempsum = tempsum/10;
        flag++;
        if(flag%3==0)
        {
            dig[k++]=-1;
        }

    }while(tempsum);
    k = k-1;
    if(dig[k]==-1){
        k--;
    }

    for(; k>=0; k--)
    {
        if(dig[k]==-1)
            cout<<",";
        else
            cout<<dig[k];

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/99108267