PAT--1113 Integer Set Partition (25 分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

代码

#include <iostream>
#include <bits/stdc++.h>

using namespace std;


int main()
{
    int n;
    int sum = 0;
    int counts = 0;
    cin>>n;
    int a[n];
    for(int i=0;i<n;i++){
        cin>>a[i];
        counts +=a[i];
    }
    sort(a,a+n);
    int flag;
    if(n%2==0){
        flag = 0;
    }else{
        flag = 1;
    }
    for(int i=0;i<n/2;i++){
        sum +=a[i];
    }

    cout<<flag<<" "<<counts-2*sum<<endl;
    return 0;
}

分析:

刚开始以为是在不改变集合顺序的情况下求,想到用 求出每个部分再求最大,但是没有思路。在借鉴其他人之后,才知道可以改变顺序,那就很简单。

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/98518275