PAT 1113 Integer Set Partition

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1​​ and n​2 numbers, respectively. Let S1​ and S​2 denote the sums of all the numbers in A​1​​ and A​2​​ , respectively. You are supposed to make the partition so that ∣n​1​​ −n​2​​ ∣ is minimized first, and then ∣S​1​​ −S​2​​ ∣ is maximized.

Input Specification:
Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10^5​​ ), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2^​31.

Output Specification:
For each case, print in a line two numbers: ∣n​1− n2​ ∣ and ∣S1​​ −S2 ∣, separated by exactly one space.

Sample Input 1:
10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:
0 3611

Sample Input 2:
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:
1 9359

#include<iostream> //水题
#include<vector>
#include<algorithm>
using namespace std;
bool cmp(const int &a, const int &b){
    return a>b;
}
int main(){
    int N, sum=0;
    cin>>N;
    vector<int> vec(N, 0);
    for(int i=0; i<N; i++)
        cin>>vec[i];
    sort(vec.begin(), vec.end(), cmp);
    int t=N%2==0?N/2:N/2+1;
    for(int i=0; i<N; i++)
        if(i<t)
            sum+=vec[i];
        else
            sum-=vec[i];
    cout<<2*t-N<<" "<<sum<<endl;
    return 0;
} 

猜你喜欢

转载自www.cnblogs.com/A-Little-Nut/p/9502011.html
今日推荐