PAT甲级——1113 Integer Set Partition (排序)

1113 Integer Set Partition (25 分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

题目大意: 将N个整数分成两个集合S1、S2(S1和S2分别为当前集合的元素之和),元素个数分别为n1、n2;找出使得|n1-n2|最小、同时|S1-S2|最大的分类操作,并输出|n1-n2|和|S1-S2|的值。

思路:数组从小到大排序,前一半是S2,后一半是S1,送分题~

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	int N;
	scanf("%d",&N);
	vector<int> v(N);
	for(int i=0;i<N;i++){
		scanf("%d",&v[i]);
	}
	sort(v.begin(),v.end());
	int n2=N/2,n1=N-n2,S1=0,S2=0;
	for(int i=0;i<n2;i++)
		S2+=v[i];
	for(int i=n2;i<N;i++)
		S1+=v[i];
	printf("%d %d",n1-n2,S1-S2);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44385565/article/details/89949463
今日推荐