1113. Integer Set Partition (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_38449464/article/details/79004020

1113. Integer Set Partition (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a set of N (> 1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that |n1 - n2| is minimized first, and then |S1 - S2| is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2 <= N <= 105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: |n1 - n2| and |S1 - S2|, separated by exactly one space.

Sample Input 1:
10
23 8 10 99 46 2333 46 1 666 555
Sample Output 1:
0 3611
Sample Input 2:
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85
Sample Output 2:
1 9359
题意:给出n个数据,要求把其分为两组,使得两组的元素个数之差最小 并且 两组值总和之差最大

分析:_(:з」∠)_ 是因为前面那题太坑了所以这题这么水吗

         个数差最小,很明显一半一半,偶数差就是0了,奇数差就是1

         值差最大,排序一下,后半段减前半段就行了

         虽然交上去是AC,但是我总感觉真实的题意被我略过了……

扫描二维码关注公众号,回复: 6047067 查看本文章

        (在想集合set要不要考虑重复的数字)

代码:

#include <iostream>       
#include <vector>         
#include <algorithm>
using namespace std;
vector<int> num;
int main ()
{
	int n=0,sum=0,s=0;
	cin >> n;
	for(int i=0;i<n;i++)
	{
		int tmp;
		cin>>tmp;
		num.push_back(tmp);
		s+=tmp;
	}
	sort(num.begin(),num.end());
	for(int i=0;i<n/2;i++)
		sum+=num[i];
	cout<<n%2<<" "<<s-2*sum<<endl;
}




猜你喜欢

转载自blog.csdn.net/qq_38449464/article/details/79004020
今日推荐