poj-2456 Aggressive cows(二分)

Aggressive cows

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19678   Accepted: 9314

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

扫描二维码关注公众号,回复: 2303256 查看本文章

Source

USACO 2005 February Gold

二分搜索,最大化距离的最小值

从无穷大不断二分,看距离是否合适,合适,扩大,不合适,缩小;

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;

int a[100010];
int n,c;
const int INF=0x3f3f3f3f;

bool f(int x){
    int k = 0,ans = 1,i;
    while(ans < c){
        for(i = k+1;i < n;i++){
            if(a[i]-a[k] >= x){
                ans++;
                k = i;
                break;
            }
        }
    if(ans == c) return true;
    if(i==n) return false;
    }
    return false;
}

int main()
{
    while(cin >> n >>c){
        int i;
        for(i = 0;i < n;i++)
            cin >> a[i];
        sort(a,a+n);
        int l = 0,r = INF;
        while(r-l > 1){
            int mid = (l+r)/2;
            if(f(mid)) l = mid;
            else r = mid;
        }
        cout << l << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81149176
今日推荐