购物车(Java集合框架)

购物车

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

各位亲爱的小伙伴们,大家好!

欢迎来到美美自助购物商场,首先请您帮忙建立商品信息,然后选购商品、确定数量,计算出总价格到结算中心进行结算。美美祝您购物愉快噢!

首先读取N行商品信息,每行包含:商品编号、商品名称、生产商、商品价格、库存数量;

接着输入M行购买信息:商品编号、商品数量、购买标志。

输出购物车中的商品数量T,以及T种商品的详细信息(商品编号、商品名称、生产商、商品价格、库存数量)、实际购买数量和购物车商品总价格(保留2位小数)。

美美商场友情提示:商品数量充分时,您才能购买;另外,您购物成功后,一定要记得增减商品库存数量噢!

Input

首行是商品种类的数量N;

接下来是N行的商品信息,每行商品信息为:商品编号、商品名称、生产商、商品价格、库存数量;

购物操作的次数M;

接下来是M行的商品购买操作的信息,每行购买信息为:商品编号、购买数量count(count>0)、购买标志(1--购买,购物车中该商品数量增加;2--退货,购物车中该商品数量减少,3-删除商品,删除操作时count列的值无效)。

Output

购物车中商品的数量T;

扫描二维码关注公众号,回复: 2434681 查看本文章

购物车中的所有商品详情,每种商品详情占一行,中间数据用1个空格符隔开。商品详情包括:商品编号、商品名称、生产商、商品价格、商品最新库存数量、已购买的商品数量。(商品价格保留2位小数),按照商品编号从小到大的顺序进行输出。若T=0,则无商品详情信息输出。

最后一行输出购物车中商品的总价格。(保留2位小数)

Example Input

5
1 运动鞋  Adidas  300.80   10
2 蓝球服  李宁    268.00    10
3 苹果    栖霞    5.00	     500
4 智能手表  苹果  4888.00   10
5 鼠标   罗技     120.00    50
9
1 5 1
3 5 1
4 1 1
3 2 2
5 2 1 
1 2 1
5 0 3
3 1 1
3 5 2

Example Output

2
1 运动鞋 Adidas 300.80 3 7
4 智能手表 苹果 4888.00 9 1
6993.60

Hint

1、购买商品的实际数量要小于或等于库存数量,退货时的数量要小于购物车中该商品的现有数量。

2、购买行为发生时,注意库存的变化。购买商品之后减库存,退货之后加库存。

3、购物车中某商品的实际数量为0时,就移除它。

Author

zhouxq

import java.util.Scanner;
import java.util.Map;
import java.util.TreeMap;

class Goods {
	int id; //商品编号
	String name; //商品名字
	String producer; //生产商
	double cost; //商品价格
	int amount; //商品剩下的数量
	int sells; //卖出去的商品数量
	
	public Goods(int id, String name, String producer, double cost, int amount, int sells) {
		this.id = id;
		this.name = name;
		this.producer = producer;
		this.cost = cost;
		this.amount = amount;
		this.sells = sells;
	}
	
}

public class Main {
	
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		//存放商品类信息,TreeMap可以直接对键进行排序,方便输出
		Map<Integer,Goods> map = new TreeMap <Integer,Goods>();
		int n = in.nextInt();
		for ( int i = 0; i < n; i++ ) {
			//初始化
			Goods goods = new Goods(in.nextInt(),in.next(),in.next(),in.nextDouble(),in.nextInt(),0);
			map.put(goods.id, goods);
		}
		int m = in.nextInt();
		for ( int i = 0; i < m; i++ ) {
			int id = in.nextInt(); //商品编号
			int count = in.nextInt(); //商品数量
			int symbol = in.nextInt(); // 购买标志
			Goods goods = map.get(id); //获取id这个键所对应的值
			if ( symbol == 1 ) {
				if ( count > goods.amount ) {
					goods.sells += goods.amount;
					goods.amount = 0;
				} else {
					goods.amount -= count;
					goods.sells += count;
				} 
			} else if ( symbol == 2 ) {
				if ( count > goods.sells ) {
					goods.amount += goods.sells;
					goods.sells = 0;
				}
				else {
					goods.amount += count;
					goods.sells -= count;
				}
			} else if ( symbol == 3 ) {
				goods.amount += goods.sells;
				goods.sells = 0;
			}
			map.put(id, goods);
		}
		int cnt = 0;
		//在map中对值进行遍历
		for ( Goods goods : map.values() ) {
			if ( goods.sells > 0 ) {
				cnt++;
			}
		}
		System.out.println(cnt);
		double sumMoney = 0;
		for ( Goods goods : map.values() ) {
			if ( goods.sells > 0 ) {
				System.out.println(goods.id + " " + goods.name + " "+ goods.producer + " "
						+String.format("%.2f",goods.cost) + " " + goods.amount + " " + goods.sells);    
                sumMoney += goods.cost * goods.sells;
			}
		}
		System.out.println(String.format("%.2f", sumMoney));
		in.close();
	}

}
/*不要考虑最后对买到的商品进行运算,在商品类里面进行记录卖出去的商品和它的数量
最后在输出时只需要对商品类检测一下,看看哪些卖出去的数量不是初始值0即可
卖出去的商品的数量就是所进行购买的数量,将进行购买的数量与退货数量均对卖出的数量这一变量进行操作*/


猜你喜欢

转载自blog.csdn.net/youth_mr6/article/details/70304900
今日推荐