JAVA-购物车

购物车

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

各位亲爱的小伙伴们,大家好!

欢迎来到美美自助购物商场,首先请您帮忙建立商品信息,然后选购商品、确定数量,计算出总价格到结算中心进行结算。美美祝您购物愉快噢!

首先读取N行商品信息,每行包含:商品编号、商品名称、生产商、商品价格、库存数量;

接着输入M行购买信息:商品编号、商品数量、购买标志。

输出购物车中的商品数量T,以及T种商品的详细信息(商品编号、商品名称、生产商、商品价格、库存数量)、实际购买数量和购物车商品总价格(保留2位小数)。

美美商场友情提示:商品数量充分时,您才能购买;另外,您购物成功后,一定要记得增减商品库存数量噢!

Input

首行是商品种类的数量N;

接下来是N行的商品信息,每行商品信息为:商品编号、商品名称、生产商、商品价格、库存数量;

购物操作的次数M;

接下来是M行的商品购买操作的信息,每行购买信息为:商品编号、购买数量count(count>0)、购买标志(1--购买,购物车中该商品数量增加;2--退货,购物车中该商品数量减少,3-删除商品,删除操作时count列的值无效)。

Output

购物车中商品的数量T;

扫描二维码关注公众号,回复: 52106 查看本文章

购物车中的所有商品详情,每种商品详情占一行,中间数据用1个空格符隔开。商品详情包括:商品编号、商品名称、生产商、商品价格、商品最新库存数量、已购买的商品数量。(商品价格保留2位小数),按照商品编号从小到大的顺序进行输出。若T=0,则无商品详情信息输出。

最后一行输出购物车中商品的总价格。(保留2位小数)

Sample Input

5
1 运动鞋  Adidas  300.80   10
2 蓝球服  李宁    268.00    10
3 苹果    栖霞    5.00	     500
4 智能手表  苹果  4888.00   10
5 鼠标   罗技     120.00    50
9
1 5 1
3 5 1
4 1 1
3 2 2
5 2 1 
1 2 1
5 0 3
3 1 1
3 5 2

Sample Output

2
1 运动鞋 Adidas 300.80 3 7
4 智能手表 苹果 4888.00 9 1
6993.60

Hint

1、购买商品的实际数量要小于或等于库存数量,退货时的数量要小于购物车中该商品的现有数量。

2、购买行为发生时,注意库存的变化。购买商品之后减库存,退货之后加库存。

3、购物车中某商品的实际数量为0时,就移除它。

Source

import java.util.*;
import java.util.Map.Entry;

class Goods {
	int id;
	String name;
	String manu;
	double price;
	int num;
	int selled;

	public Goods(int id, String name, String manu, double price, int num, int selled) {
		super();
		this.id = id;
		this.name = name;
		this.manu = manu;
		this.price = price;
		this.num = num;
		this.selled = selled;
	}

}

public class Main {
	public static void main(String[] args) {
		Scanner re = new Scanner(System.in);
		Map<Integer, Goods> map = new TreeMap<Integer, Goods>();
		int n, m;
		n = re.nextInt();
		while (n-- > 0) {
			int id = re.nextInt();
			String name = re.next();
			String manu = re.next();
			double price = re.nextDouble();
			int num = re.nextInt();
			Goods good = new Goods(id, name, manu, price, num, 0);
			map.put(good.id, good);
		}
		m = re.nextInt();
		while (m-- > 0) {
			int id = re.nextInt();
			int count = re.nextInt();
			int f = re.nextInt();
			Goods x = map.get(id);
			if (f == 1) {
				if (count > x.num) {
					x.selled += x.num;
					x.num = 0;
				} else {
					x.selled += count;
					x.num -= count;
				}
			} else if (f == 2) {
				if (x.selled < count) {
					x.num += x.selled;
					x.selled = 0; 
				} else {
					x.num += count;
					x.selled -= count;
				}
			} else if (f == 3) {
				x.num += x.selled;  //删除商品时库存一定加上卖出的商品数量
				x.selled = 0; 
			}
			map.put(x.id, x);       //修改完成后记得把值存入map中
		}
		Iterator<Entry<Integer, Goods>> it = map.entrySet().iterator();     //map中的迭代器
		while (it.hasNext()) {
			Entry<Integer, Goods> next = it.next();
			if (next.getValue().selled == 0)
				it.remove();
		}
		System.out.println(map.size());
		double sum = 0;
		for (Goods good : map.values()) {
			System.out.printf("%d %s %s %.2f %d %d\n", good.id, good.name, good.manu, good.price, good.num,
					good.selled);
			sum += good.selled * good.price;
		}
		System.out.printf("%.2f\n", sum);
		re.close();
	}
}

本篇博客结合了一下别人的思路,个人写了一些自己理解的Map。

猜你喜欢

转载自blog.csdn.net/kksimida/article/details/80055756
今日推荐