白书模板 poj2456 Aggressive cows

基础二分 水题 http://poj.org/problem?id=2456

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
const int maxn = 1e6+10;

int a[maxn];
int n, c;

int check(int x)
{
	int cnt = 1;
	int temp = a[0];
	for(int i=1; i<n; i++)
	{
		if(a[i]-temp>=x)
		{
			cnt++;
			temp = a[i];
		}
		if(cnt>=c) break;
	}
	return cnt>=c?1:0;
}

int main()
{
	int i;
	while(cin>>n>>c)
	{
		for(i=0; i<n; i++)
		{
			scanf("%d", &a[i]);
		}
		sort(a, a+n);
		int l=0, m, r=a[n-1]-a[0];
		while(r>l+1)
		{
			m = (l+r)/2;
			if(check(m))
				l = m;
			else r = m;
		}
		cout<<l<<endl;
	}

	return 0;
}

一开始输出了m,样列过了然后疯狂wa,发现取m可能超,应该用l

猜你喜欢

转载自blog.csdn.net/Jqmjyj/article/details/81782324
今日推荐