Aggressive cows-NYOJ 586 疯牛 POJ 2456

转载: https://blog.csdn.net/wuxiushu/article/details/49158843 

Aggressive cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8752   Accepted: 4349

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

代码:与原文相比主要加了个注释,主要是为了做笔记,不喜勿喷~~~

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int n,m,k[100010];
int judge(int d){//判断是否满足条件 
	int count=1,a=k[0]; 
	for(int i=1;i<n;i++){
		if(k[i]-a>=d){//找一个满足条件的值,则进行更新,因为要找到间距最小的最大值 
			count++;
			a=k[i];
		}
		if(count>=m) return true;
	}
	return false;
}
int binarysearch()
{
	int x=0,y=k[n-1]-k[0];//二分所有可能的结果 
	while(x<=y){
		int mid=(x+y)/2;
		if(judge(mid)) x=mid+1;//满足条件则接着找更大的值 
		else y=mid-1;
	}
	return x-1;
}
int main()
{
	while(~scanf("%d%d",&n,&m)){
		for(int i=0;i<n;i++) scanf("%d",&k[i]);
		sort(k,k+n);
		printf("%d\n",binarysearch());
	}
}






猜你喜欢

转载自blog.csdn.net/dadaguai001/article/details/81002081
今日推荐