PAT 甲级 1099 Build A Binary Search Tree(中序遍历)

1099 Build A Binary Search Tree (30)(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

Analysis:

pta haven't upadated this problem altogether,so if you scan without figure 1 and 2,you are likely to be puzzled a lot.......

Anyway,,,,,,

1 you should have a grasp of the definition of the bst(the left subtree is smaller than the root ,and the root is smaller than the right subtree).

2.how to stuff the key integer into the  binary tree? you can find the regulation that inorder  traserval can visit these nodes ascendingly, so polish the inorder traserval and fill Integers in.

3.what's more?   level traserval usually needs a queue to maintain .Now ,with the special inorder traserval ,you can use a vector to record a node according to the level it lies.That is to make our code shorter.  

4.it 's better to build the tree in static array rather than a linkedlist.

C++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct tree{
	int left;
	int right;
};
struct tree bst[101];
int key[101];
int counter=0;
vector<int>v[101];
void inorderTraservalAC(int k,int level)
{
	if(k!=-1){
		inorderTraservalAC(bst[k].left,level+1);
		v[level].push_back(key[counter++]);//the key code ,fill the nodes into the vector to print
		inorderTraservalAC(bst[k].right,level+1);
	}
}
int main()
{
	freopen("1099 Build A Binary Search Tree.txt","r",stdin);
	int n,flag=1;
	cin>>n;
	for(int i=0;i<n;i++){
		int l,r;
		cin>>l>>r;
		bst[i]={l,r};//record
	}
	for(int i=0;i<n;i++)
		cin>>key[i];//record
	sort(&key[0],&key[n]);
	inorderTraservalAC(0,0);//simulate 
	for(int i=0;i<100;i++){
		if(v[i].size()==0)
			break;
		for(int j=0;j<v[i].size();j++){
			if(flag){
				flag=0;
				printf("%d",v[i][j]);
			}
			else
				printf(" %d",v[i][j]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/81808297