HDUOJ 2674 N!Again

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wangke1998/article/details/80781893

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5915    Accepted Submission(s): 3149


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
 
  
4 5
 

Sample Output
 
  
24 120
 

Author
WhereIsHeroFrom
 

Source

AC:

#include<stdio.h>
int main()
{
	int n,mod,i,sum;
    int a[50];
    a[0]=1;
    for(i=1;i<=50;i++)
    {
    	a[i]=(a[i-1]*i)%2009;
	}
	while(scanf("%d",&n)!=EOF)
	{
		if(n>40)
		  printf("0\n");
		else
		  printf("%d\n",a[n]);
	}
    return 0;	
}

因为2009=41*7*7;

所以,41之后的都为0.

猜你喜欢

转载自blog.csdn.net/wangke1998/article/details/80781893