poj 1703并查集路径压缩

Language:Default

Find them, Catch them

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 53910   Accepted: 16522

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

种类并查集加路径压缩和食物链那道题相似

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 100005
using namespace std;
int father[maxn];
int r[maxn];
int rev(int val)
{
    return val;
}
int real(int v1,int v2)
{
    if(v1==0)
    return v2;
    if(v2==0)
    return v1;
    if(v1==1&&v2==1)
    return 0;
}
int real3(int v1,int v2,int v3)
{
    return real(real(v1,v2),v3);
}
int find(int x)
{
    if(father[x]==x)
    return x;
    int root=find(father[x]);
    r[x]=real(r[x],r[father[x]]);
    return father[x]=root;
}
int unionn(int u,int v,int relation)
{
    int fu=find(u);
    int fv=find(v);
    if(fu!=fv)
    {
        r[fu]=real3(rev(r[u]),relation,r[v]);
        father[fu]=fv;
        return 1;
    }
    return 0;
}
int getreal(int u,int v)
{
    int fu=find(u);
    int fv=find(v);
    if(fu!=fv)
    return -1;
    return real(r[u],rev(r[v]));
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        for(int i=0;i<=n;i++)
        father[i]=i;
        memset(r,0,sizeof(r));

        while(k--)
        {
            char op[10];
            int u,v;
            scanf("%s%d%d",op,&u,&v);
            if(op[0]=='A')
            {int relation=getreal(u,v);
                  if(relation==-1) printf("Not sure yet.\n");
                else if(relation==0) printf("In the same gang.\n");
                else if(relation==1) printf("In different gangs.\n");


            }
            else if(op[0]=='D')
            unionn(u,v,1);

        }

    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/83175826