PAT 甲级 1019 General Palindromic Number(进制转换)

1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0N > 0N>0 in base b≥2b \ge 2b≥2, where it is written in standard notation with k+1k+1k+1 digits aia_ia​i​​ as ∑i=0k(aibi)\sum_{i=0}^k (a_ib^i)∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤ai<b0 \le a_i < b0≤a​i​​<b for all iii and aka_ka​k​​ is non-zero. Then NNN is palindromic if and only if ai=ak−ia_i = a_{k-i}a​i​​=a​k−i​​ for all iii. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer NNN and a base bbb, you are supposed to tell if NNN is a palindromic number in base bbb.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers NNN and bbb, where 0<N≤1090 < N \le 10^90<N≤10​9​​ is the decimal number and 2≤b≤1092 \le b \le 10^92≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if NNN is a palindromic number in base bbb, or No if not. Then in the next line, print NNN as the number in base bbb in the form "aka_ka​k​​ ak−1a_{k-1}a​k−1​​ ... a0a_0a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

C++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int base[1000000];
int main()
{
	int n,b,i=0,j;
	cin>>n>>b;
	while(n!=0){
		base[i++]=n%b;
		n=n/b;
	}
	for( j=0;j<=i/2;j++)
		if(base[j]!=base[i-j-1]){
			cout<<"No";
			break;
		}
	if(j==i/2+1)cout<<"Yes";
	cout<<endl<<base[i-1];
	for(int j=i-2;j>=0;j--)
		cout<<" "<<base[j];
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/82986330