POJ 2406 Power Strings(KMP:找串循环节)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sdz20172133/article/details/84455535

Power Strings

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 60362   Accepted: 24990

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

算法分析:

分析:poj 1961 Period          (KMP+最小循环节)

代码实现:

#include<cstdio>
#include<iostream>
#include<fstream>
#include<algorithm>
#include<functional>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<numeric>
#include<cctype>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
 
const int N = 1000002;
int nxt[N];
char  T[N];
int  tlen;
 
void getNext()
{
    int j, k;
    j = 0; k = -1;
	nxt[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
           {
           	nxt[++j] = ++k;
           	if (T[j] != T[k]) //优化
				nxt[j] = k; 
           } 
        else
            k = nxt[k];
 
}


int main()
{
 
    int TT;
	
	int kase=1;
    while(scanf("%s",&T)!=-1)
    {
    	tlen= strlen(T);
    	if(tlen==1&&T[0]=='.')
    		break;
   
		getNext();
      
	   	if(tlen%(tlen-nxt[tlen])==0)
       	printf("%d\n",tlen/(tlen-nxt[tlen]));
         else
         	printf("1\n");
       	 
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/84455535