Power Strings POJ - 2406 (KMP找循环节)

版权声明:转载请标明出处 https://blog.csdn.net/weixin_41190227/article/details/86562682

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意:就是在字符串中找相同子串最多的个数。

解题思路:用kmp的Next数组找字符串的最小循环节,用长度整除就可以了。需要注意一点,要判断一下长度是否可以整除,因为如果不能整除,说明最小循环节的长度是len,输出1即可。

/*
@Author: Top_Spirit
@Language: C++
*/
//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std ;
typedef unsigned long long ull ;
typedef long long ll ;
const int Maxn = 1e6 + 10 ;
const int INF = 0x3f3f3f3f ;
const ull seed = 133 ;
const double PI = acos(-1.0) ;

char s[Maxn] ;
int Next[Maxn] ;
int len ;

void getNext(){
    Next[0] = -1 ;
    int j = 0, k = -1;
    while (j < len){
        if (k == -1 || s[j] == s[k]) Next[++j] = ++k ;
        else k = Next[k] ;
    }
}

int main (){
    while (~scanf("%s",s) && s[0] != '.'){
        len = strlen(s) ;
        getNext() ;
        int tmp = len % (len - Next[len]) ;
        if (!tmp) printf("%d\n", len / (len - Next[len])) ;
        else puts("1") ;
    }
    return 0 ;
}

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/86562682