poj2406--Power Strings (KMP)

点击打开链接

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

  就是问一个字符串写成(a)^n的形式,求最大的n.
根据KMP的next函数的性质,已知字符串t第K个字符的next[k],那么d=k-next[k],如果k%d==0,那么t[1……k]最多可均匀的分成k/d份。也就是可以生成一个长度为d的重复度为k/d的字串

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1000005;
int m,next[maxn];
char s[maxn];
void getnext()
{
	int i=0,j=0;
	next[0]=-1;
	j=next[i];
	while(i<m)
	{
		if(j==-1||s[i]==s[j])
		{
			next[++i]=++j;
		}
		else
		{
			j=next[j];
		}
	}
}
int main()
{
	while(scanf("%s",s)!=EOF)
	{
		if(s[0]=='.')
		break;
		m=strlen(s);
		getnext();
		int n=1;
		if(m%(m-next[m])==0)
		n=m/(m-next[m]);
		printf("%d\n",n);
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/crystaljy/article/details/77317962