Power Strings
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 73134 | Accepted: 30196 |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
next数组很重要的应用——求循环节
当n%(n-next[n])==0 为有循环节 个数为n/(n-next[n])
代码
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
char c[1000005];
int p[1000005];
void next(int len)
{
p[0]=-1;
int i=0,j=-1;
while(i<len)
{
if(j==-1 || c[i]==c[j]) i++,j++,p[i]=j;
else j=p[j];
}
}
int main()
{
freopen("a.in","r",stdin);
freopen("a.out","w",stdout);
while(scanf("%s",c) && c[0]!='.')
{
memset(p,0,sizeof(p));
int len=strlen(c);
next(len);
int ans=1;
if(len%(len-p[len])==0)
ans=len/(len-p[len]);
printf("%d\n",ans);
}
return 0;
}