Power Strings 【poj-2406】【KMP】

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 50546   Accepted: 21082

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3


题解:假设S的长度为len,则S存在循环子串,当且仅当,len可以被len - next[len-1]整除,最短循环子串为S[len - next[len-1]]

根据算法的不同,这里的next[len-1]代表整个字符串(即算上最后一位字符)的最大匹配值。

若不能整除,输出1;


代码如下:


#include<cstdio>
#include<cstring>

char P[1000005];
int Next[1000005];

int main()
{
	while(~scanf("%s",P)){
		if(P[0]=='.') break;
		int i,k=0;
		memset(Next,0,sizeof(Next));
		int n=strlen(P);
		Next[0]=0;
		for(i=1;i<n;i++){
			while(k>0&&P[i]!=P[k])
				k=Next[k-1];
			if(P[i]==P[k])
				k++;
			Next[i]=k;
			
		}
		
		if(n%(n-Next[n-1])==0)
			printf("%d\n",n/(n-Next[n-1]));
		else
			printf("1\n");
		
		
	}
	
	return 0;
}





发布了79 篇原创文章 · 获赞 5 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/DNMTOOBA/article/details/77216206