POJ - 2406 Power Strings KMP(最小循环节)

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

求字符串中最小的循环节。

如果对于next数组中的 i, 符合 i % ( i - next[i] ) == 0 && next[i] != 0 , 则说明字符串循环,而且

循环节长度为:   i - next[i]

循环次数为:   i / ( i - next[i] )

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
#define N 1000000
int next[N],len;
char s[N];
void GetNext()
{
    len=strlen(s);
    int i=0,j;
    j=next[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }else j=next[j];
    }
}
int main()
{
    while(scanf("%s",s))
    {
        if(s[0]=='.')break;
        GetNext();
        if(len%(len-next[len])==0)
        {
            printf("%d\n",len/(len-next[len]));
        }else printf("1\n");
    }return 0;
}
/*
循环节长度为: len - next[len]

循环次数为:     len/(len-next[len])
*/

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81668480