POJ - 2406 Power Strings next数组应用循环节

题目链接:点击查看

Language:Default

Power Strings

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 61784   Accepted: 25534

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意:给出一个字符串 问它最多由多少相同的子串组成 

题解:判断是否全部由循环子串构成即可 即判断  len % ( len - nex[len] ) 是否为0

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=1e6+10;
char s[N];
int nex[N],len;
void getnex()
{
	int i=0,j=-1;
	nex[0]=-1;
	while(i<len)
	{
		if(j==-1||s[i]==s[j]) nex[++i]=++j;
		else j=nex[j];
	}
}
int main()
{
	while(~scanf("%s",s)&&s[0]!='.')
	{
		len=strlen(s);
		getnex();
		if(len%(len-nex[len])) printf("%d\n",1);
		else printf("%d\n",len/(len-nex[len]));
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/mmk27_word/article/details/86716003