Adjacent Bit Counts

For a string of n bits x1, x2, x3,…, xn, the adjacent bit count of the string (AdjBC(x)) is given by
x1 ∗ x2 + x2 ∗ x3 + x3 ∗ x4 + . . . + xn−1 ∗ xn
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:
AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0
Write a program which takes as input integers n and k and returns the number of bit strings x of nbits (out of 2n) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting
AdjBC(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that
follow. Each data set is a single line that contains the data set number, followed by a space, followed by
a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by
a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater
than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.
Output
For each data set there is one line of output. It contains the data set number followed by a single space,
followed by the number of n-bit strings with adjacent bit count equal to k.
Sample Input
10
1 5 2
2 20 8
3 30 17
4 40 24
5 50 37
6 60 52
7 70 59
8 80 73
9 90 84
10 100 90
Sample Output
1 6
2 63426
3 1861225
4 168212501
5 44874764
6 160916
7 22937308
8 99167
9 15476
10 23076518

题意

給你一个长度为n的01字符串s,问你按照题目所給方式计算AdjBC(s),有多少种长度为n的01字符串的AdjBC值为k。
AdjBC(s) = x 1 x_1 * x 2 x_2 + x 2 x_2 * x 3 x_3 + x 3 x_3 * x 4 x_4 + \dots + x n 1 x_{n-1} * x n x_n

思路

找规律的题,可以用动态规划来搞一搞。
观察发现:

  • 长度为n+1的字符串由长度为n的字符串通过在最前面增加一个1或0得到。
  • 在一个串前加一个0不改变串的AdjBC。
  • 在一个串前加一个1取决于原串最前面的字符,若原串最前面是1,新串的AdjBC值等于原串AdjBC值+1, 否则等于原串AdjBC值。

设:dp[i][j][k]

  • i 代表长度为i的字符串
  • j 代表该串的AdjBC值
  • k 代表该串最前面的字符是1还是0

根据规律有动态转移方程:
dp[i][j][0] = dp[i - 1][j][0] + dp[i - 1][j][1]
dp[i][j][1] = dp[i - 1][j - 1][1] + dp[i - 1][j][0]
特殊的:
当 j == 0 时,dp[i][j][1] = dp[i - 1][j][0]

Code

#include <bits/stdc++.h>
#define N 110
#define INF 0x3f3f3f3f
using namespace std;

int dp[N][N][2];

void Solve()
{
    dp[1][0][0]=1;
    dp[1][0][1]=1;
    for(int i=2; i<=100; i++)
    {
        for(int j=0; j<i; j++)
        {
            if(j==0)
            {
                dp[i][j][1]=dp[i-1][j][0];
                dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];
            }
            else
            {
                dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];
                dp[i][j][1]=dp[i-1][j-1][1]+dp[i-1][j][0];
            }
        }
    }
}

int main()
{
    Solve();
    int T,z,b,m;
    cin>>T;
    while(T--)
    {
        cin>>z>>b>>m;
        cout<<z<<" "<<dp[b][m][0]+dp[b][m][1]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codertcm/article/details/83064556
BIT