Tian Ji -- The Horse Racing(贪心)

Tian Ji – The Horse Racing    HDU - 1052

https://cn.vjudge.net/problem/HDU-1052
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
Sample Output
200
0
0

思路

f是田忌,g是齐王
先排序,从大到小
头f大于g头或f尾大于g尾,直接ans++;进入下次循环
当f尾小于g尾,既然f的尾已经最小,那么直接让f的尾去和g的头比较,最大化牺牲
当f头等于g头,f尾等于g尾,让f尾去和g尾比较,因为头的比重大;
剩下的就只能输了,输也要利益最大化,ans–;f的尾和g的头去比较

代码
#include <bits/stdc++.h>
using namespace std;
int f[10000],g[10000];
bool cmp(int a,int b){
    return a>b;
}
int main(){
    int n;
    while(scanf("%d", &n),n){
        for(int i=0;i<n;i++)
            scanf("%d", &f[i]);
        for(int j=0;j<n;j++)
            scanf("%d", &g[j]);
        sort(f,f+n,cmp);
        sort(g,g+n,cmp);
        int xb=0,xe=n-1,yb=0,ye=n-1;
        int ans=0;
        while(n--){
            if(f[xe]>g[ye]){
                ans++;
                xe--;
                ye--;
            }else if(f[xb]>g[yb]){
                ans++;
                xb++;
                yb++;
            }else if(f[xe]<g[yb]){
                ans--;
                yb++;
                xe--;
            }else if(f[xe]==g[ye]&&f[xb]==g[yb]){
                xe--;
                ye--;
            }else{
                ans--;
                xe--;
                yb++;
            }
        }
        printf("%d\n", ans*200);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44410512/article/details/88227431