hdu_1052 Tian Ji -- The Horse Racing 贪心

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40477    Accepted Submission(s): 12148


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 
Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 
Sample Input
3
92 83
71 95
87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output
200
0
0

思路:
一共要分 n 组比赛,每次分三种情况:
  1. 用田忌的坏马与齐王的坏马比较,能获胜继续下一组,否则进行 2 。 
  2. 用田忌的好马与齐王的好马比较,能获胜继续下一组, 否则进行 3 。
  3. 用田忌的坏马与齐王的好马比较,这时候只有两种情况,坏马<好马 和 坏马=好马。
 
要注意坏马与坏马比较时候, 就算相等也不是最好的情况, 应该用这匹坏马与齐王的好马比。 这样才能给后面的分组带来更大的优势。
 
#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;

int main()
{
    int a[1005],b[1005],n,win,lose;

    while(scanf("%d",&n) && n)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d", &a[i]);
        }
        for(int i=0; i<n; i++)
        {
            scanf("%d", &b[i]);
        }

        sort(a, a+n);
        sort(b, b+n);

        int Tslow=0, Tfast=n-1, Kslow=0, Kfast=n-1;
        win=0;
        while(n--)
        {
            if(a[Tslow] > b[Kslow])
            {
                win++;
                Tslow++;
                Kslow++;
            }
            else if(a[Tfast] > b[Kfast])
            {
                win++;
                Tfast--;
                Kfast--;
            }
            else if(a[Tslow]<b[Kfast])
            {
                win--;
                Tslow++;
                Kfast--;
            }
            else if(a[Tslow]==b[Kfast])
                continue;
            else printf("e");
        }

        printf("%d\n", win*200);

    }
    return 0;
}
 
 

猜你喜欢

转载自www.cnblogs.com/Dawn-bin/p/10800944.html