扩展域的并查集(2)

Training 4 - E题

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。

现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。

有人用两种说法对这N个动物所构成的食物链关系进行描述:

第一种说法是"1 X Y",表示X和Y是同类。

第二种说法是"2 X Y",表示X吃Y。

此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。

1) 当前的话与前面的某些真的话冲突,就是假话;

2) 当前的话中X或Y比N大,就是假话;

3) 当前的话表示X吃X,就是假话。

你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

   第一行是两个整数N和K,以一个空格分隔。 
   
   以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 
   
   若D=1,则表示X和Y是同类。 
   
   若D=2,则表示X吃Y。

Output

   只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5

Sample Output

3

#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 3 * 5e4 + 5;

int fa[maxn];

void initial(int n)
{
	for (int i = 1; i <= 3 * n; i++)
	{
		fa[i] = i;
	}
}

int get(int x)
{
	if (x == fa[x])
		return x;
	return fa[x] = get(fa[x]);
}

int main()
{
	int n, k;
	int ans = 0;
	scanf("%d%d", &n, &k);
	initial(n);
	while (k--)
	{
		int d, x, y;
		scanf("%d%d%d", &d, &x, &y);
		if (x > n || y > n || (d == 2 && x == y))
		{
			ans++;
			continue;
		}
		if (d == 1)
		{
			if (fa[get(x + n)] == fa[get(y)] || fa[get(x)] == fa[get(y + n)])
			{
				ans++;
				continue;
			}
			fa[get(x)] = get(y);
			fa[get(x + n)] = get(y + n);
			fa[get(x + n + n)] = get(y + n + n);
		}
		if (d == 2)
		{
			if (fa[get(x)] == fa[get(y + n)] || fa[get(x)] == fa[get(y)])
			{
				ans++;
				continue;
			}
			fa[get(x + n)] = get(y);
			fa[get(x)] = get(y + n + n);
			fa[get(x + n + n)] = get(y + n);
		}
	}
	printf("%d\n", ans);
	return 0;
}

发布了28 篇原创文章 · 获赞 0 · 访问量 326

猜你喜欢

转载自blog.csdn.net/xukeke12138/article/details/104732342