POJ - 2488 A Knight's Journey

A Knight's Journey

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 51329   Accepted: 17399

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:现在给你个棋盘,然后用马的行走方式从任何位置开始如果能跳遍整个棋盘就按照最小字典序输出走过的路,不能的话输出impossible,输出的话纵列用英文字母,横行用数字

思路:开始看这道题我有点懵,就是不知道最小字典序怎么搞,后来才知道如果我们dfs从0,0点出发开始找,他在深搜遍历的过程中如果找到了就一定子最小的字典序。最后还要记录路径,我用二维数组记录的

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
int n,q,p,flag;
int vis[50][50],mapp[50][50];
int dx[8]= {-1,1,-2,2,-2,2,-1,1};
int dy[8]= {-2,-2,-1,-1,1,1,2,2};
int judge(int x,int y)
{
    if(x>=0&&x<p&&y>=0&&y<q&&!vis[x][y])
        return 1;
    return 0;
}
void dfs(int x,int y,int step)
{
    vis[x][y]=1;
    if(step==q*p)
    {
        flag=1;
        return ;
    }
    for(int i=0; i<8; i++)
    {
        int xx=x+dx[i];
        int yy=y+dy[i];
        if(judge(xx,yy))
        {
            mapp[step][0]=xx;
            mapp[step][1]=yy;
            dfs(xx,yy,step+1);
            vis[xx][yy]=0;
            if(flag)
                return ;
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&p,&q);
            memset(vis,0,sizeof(vis));
            memset(mapp,0,sizeof(mapp));
            int step=1;
            flag=0;
            dfs(0,0,step);
            printf("Scenario #%d:\n",i);
            if(flag)
            {
                for(int j=0; j<q*p; j++)
                    printf("%c%d",mapp[j][1]+'A',mapp[j][0]+1);
                printf("\n");
            }
            else
            {
                printf("impossible\n");
            }
            printf("\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/zezzezzez/article/details/81195709